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Registration Info Editor is a tool for adding, modifying, or updating application-integration 
information in the registration database. 
To learn how to use Help, press F1. 
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What Is the Registration Database?
The registration database is a source of information about applications. This information 
is used when you open or print a file from File Manager, and by applications that support 
object linking and embedding. 
The registration database (REG.DAT) is set up and maintained by Windows and Windows 
applications, and is located in the Windows directory. This file should not be moved or 
deleted. Doing so may result in a loss of functionality in File Manager, Program Manager, 
and applications that support object linking and embedding. 

See Also
Using Registration Info Editor 



Using Registration Info Editor
Registration Info Editor comes with two interfaces. The default interface appears when 
you run REGEDIT.EXE and is used for viewing and modifying registration information that 
pertains to the Open and Print commands in File Manager. The advanced interface is used
for accessing all registration information, including information used by applications that 
support object linking and embedding. To use the advanced interface, start Registration 
Info Editor with the /v option (regedit /v) by using the Run command in File Manager or 
Program Manager. 
It is recommended that you only modify information in the registration database if you 
are instructed to do so by an application vendor or a product-support technician (or you 
understand the registration information in the registration database). If you have an 
application that is not registered in the database, you can use File Manager to associate 
the application with a filename extension so that you can open files from File Manager. If 
you want to be able to print from File Manager, you must add the application's printing 
information to the registration database. If the application provides a Dynamic Data 
Exchange (DDE) interface and macro language, or a command-line option for printing, 
you may be able to add registration information to support printing from File Manager. 
Before modifying the registration database, contact your application vendor to find out if 
there is a newer version of the application that supports these Windows version 3.1 
features. 

See Also
What Is the Registration Database? 



Installing an Existing Registration File
If an application has a registration (.REG) file, the registration information is usually 
added to the registration database while the application is installed on your system. If 
you have an application that has a .REG file but is not registered in the database, you can
add it to the database by using Registration Info Editor. When you install the registration 
file, all of the application's registration information is merged into the registration 
database. 
To install a registration file
1 From the File menu, choose Merge Registration File. 
2 In the Merge Registration File dialog box, select the registration file for the application 

you want to add to the database. 
3 Choose the OK button. 
For help with the Merge Registration File dialog box, choose the Help button or press F1 
while using the dialog box. 
You can also install a registration file from File Manager by double-clicking the registration
(.REG) file or by selecting it and pressing ENTER. 



Adding a New File Type
If an application doesn't have a .REG file, you can register it in the database by specifying
a new file type. 
Note: In order to add registration information into the registration database, you must be 

familiar with the DDE interface for the application, macro commands, and 
command-line options supported by your application. Not all applications provide 
the level of support necessary to register Open and Print commands. We 
recommend you first contact your application vendor to find out if a newer version 
of your application is available that supports these features. 

If you want to add a new file type to the registration database, you can either make a 
copy of an existing file type and modify it, or you can create a new file type. 
To copy an existing file type
1 From the Registered File Types list, select the file type you want to make a copy of. 
2 From the Edit menu, choose Copy File Type. 
3 Use the Copy File Type dialog box to modify the registration information for the new file

type. You must specify a unique identifier for the new file type. 
4 Choose the OK button. 
To create a new file type
1 From the Edit menu, choose Add File Type. 
2 Use the Add File Type dialog box to specify the information for the new file type. You 

must specify a unique identifier for the new file type. 
3 Choose the OK button. 
For help with the Copy File Type or Add File Type dialog box, choose the Help button or 
press F1 while using the dialog box. 



Modifying a File Type
If you want to change the registration information for a particular file type, you can 
modify the file-type information in the registration database. 
To modify an existing file type
1 Select the file type you want to modify. 
2 From the Edit menu, choose Modify File Type. 
3 Use the Modify File Type dialog box to change any of the file-type information. You 

cannot change the identifier. 
4 Choose the OK button. 
For help with the Modify File Type dialog box, choose the Help button or press F1 while 
using the dialog box. 



Removing a File Type
If there are file types in the registration database that you do not use, you can remove 
them. 
To remove a file type from the registration database
1 From the Registered File Types list, select the file type you want to remove. 
2 From the Edit menu, choose Delete File Type. 
3 Choose the Yes button in the confirmation dialog box to remove the file type. 



Restoring the Registration Database
If your registration database (REG.DAT) has been deleted or corrupted, you can restore 
the information. 
To restore the registration database
1 Quit Windows, delete the REG.DAT file, and then restart Windows. 
2 Start Registration Info Editor. There will not be any entries in the list of registered file 

types. 
3 From the File menu, choose Merge Registration File. 
4 In the File Name list, select the SETUP.REG file, and then choose the OK button. The 

SETUP.REG file is located in the SYSTEM subdirectory of your Windows directory. 
A message appears, confirming that the information has been successfully registered. 
The registration database is updated with the original registration information that 
came with Windows. 

If you have additional applications that have registration information in a .REG file, you 
can add them to the database by choosing the Merge Registration File command from the
File menu. 

See Also
Installing an Existing Registration File 



Merge Registration File
Adds the information in an application's registration (.REG) file to the registration 
database. Use this dialog box to select the registration file you want to install. 
Choose one of the following buttons for information about the dialog box: 
 File Name 
 List Files of Type 
 Directories 
 Drives 



Exit
Quits Registration Info Editor. 



Add File Type
Creates a new file type and adds it to the registration database. Once the new file type is 
added to the database, you must use the Associate command in File Manager to 
associate filename extensions with the file type. 
Choose one of the following buttons for more information about the dialog box: 
 Identifier
 DDE Message 
 File Type
 DDE Application Not Running 
 Action
 Application 
 Command
 Topic 
 Uses DDE



Copy File Type
Copies the file-type information from the selected file type, except for the identifier, and 
adds it to the registration database. Use the Copy File Type dialog box to assign a unique 
identifier to the file type. You can also modify any of the other file-type information. 
Choose one of the following buttons for more information about the dialog box: 
 Identifier
 DDE Message 
 File Type
 DDE Application Not Running 
 Action
 Application 
 Command
 Topic 
 Uses DDE



Modify File Type
Displays the file-type information for the selected file type. Use the Modify File Type dialog
box to change any of the file-type information. You cannot change the identifier for the 
file type. 
Choose one of the following buttons for more information about the dialog box: 
 Identifier
 DDE Message 
 File Type
 DDE Application Not Running 
 Action
 Application 
 Command
 Topic 
 Uses DDE



Delete File Type
Removes the selected file type from the registration database. When you choose this 
command, a confirmation message appears, asking if you want to delete the file type. 



Browse
Use this dialog box to select a program file to enter into the Command area of the Add, 
Copy, or Modify File Type dialog box. 
Choose one of the following buttons for information about the dialog box: 
 File Name
 List Files of Type
 Directories
 Drives



Contents
Starts Help and displays the topics in Registration Info Editor Help. 



Search for Help on
Opens the Search dialog box for Registration Info Editor Help. You can look up Help 
information by using keywords in the dialog box. 



How to Use Help
Describes how to use Help. 



About Registration Editor
Displays version, mode, and copyright information about Windows. 



File Menu Commands

Merge Registration File
Merges an existing registration file into the registration database. 

Exit
Quits Registration Info Editor. 



Edit Menu Commands

Add File Type
Creates a new file type and adds it to the registration database. 

Copy File Type
Creates a copy of an existing file type in the registration database, which you can then 
rename and modify. 

Modify File Type
Modifies an existing file type in the registration database. 

Delete File Type
Deletes a file type from the registration database. 



Control Menu
The Control menu has the following commands: 

Restore
Restores the window to its former size after it has been maximized or minimized. 

Move
Enables you to use the keyboard to move the window to another position. 

Size
Enables you to use the keyboard to change the size of the window. 

Minimize
Reduces the window to an icon. 

Maximize
Enlarges the window to its maximum size. 

Close
Quits the application, or closes the window or dialog box. 

Switch To
Opens Task List, which you can use to switch between running applications and to 
rearrange their windows and icons. 



File Name
Select a filename, and then choose the OK button. 
Or type a filename in this box, and then choose the OK button. If the file is not in the 

current directory, include the path. 
If the file you want is not in the File Name list, you may have to change directories by 
choosing a directory in the Directories list. 



List Files of Type
Open the list, and then select the type of file you want to display in the File Name 

box. 



Directories
Select the directory that contains the file you want to use. The names of the files in 

that directory will appear in the File Name box. 
If the directory you want is not in the list, you may have to change drives by opening the 
Drives list and selecting a drive. 



Drives
Open the list, and then select the drive that contains the file you want. The 

directories on that drive will appear in the Directories box. 



Identifier
Specify a unique keyword to identify the file type in the registration database. 

The identifier can contain up to 63 characters. It cannot contain any spaces, extended or 
control characters, or backslashes (\). If you are modifying an existing file type, you 
cannot change the identifier. 



File Type
The File Type is a text description that is displayed in the Registration Info Editor window 
and in the Associations dialog box in File Manager. 

Specify a text description of the file type. 



Action
The options in this area are used to specify the command-line information for the file 
type. If the Open option is selected, the information in the Command and DDE areas 
specifies the action to take when opening a file. If the Print option is selected, the 
information in the Command and DDE areas specifies how to print a file. 

Select the Open option to specify the command for opening files of this file type. 
Select the Print option to specify the command for printing files of this file type. 



Command
If the Open option is selected, type the command for opening a file of this file type. If 

the Print option is selected, type the command for printing a file. 
The command line must start with the name of a program file. You can use the Browse 
button to find and select a program filename. Use the %1 replaceable parameter in the 
command line to represent a filename; for example, pbrush.exe %1. The %1 is replaced
with the filename that is selected in File Manager when the command is carried out. 
If the application supports DDE commands for opening and printing files, specify just the 
name of the program file in this area and use the DDE area to specify the DDE open and 
print commands. 



Uses DDE
Select this option if DDE commands are used to perform the selected action (open or 

print). When you select this option, you can specify the DDE commands in the DDE area of 
the dialog box. 
If this option is not selected, any DDE commands specified for the file type are deleted 
from the registration database when you choose the OK button. 



DDE Message
Specify the DDE command to use for the selected action. Use the %1 replaceable 

parameter in the DDE command line to represent a filename. The %1 is replaced with the 
file currently selected in File Manager when the command is carried out. If the Open option is
selected, specify the DDE command for opening a file; for example, [open("%1")]. If the 
Print option is selected, specify the DDE command for printing a file; for example, 
[open("%1")][print()][close()]. 

To use this option, you must be using an application that supports DDE commands, 
and the Uses DDE check box must be selected. 



DDE Application Not Running
This is optional and is useful only when printing with certain applications. Specify the 

DDE command to use if the application is not already running. The command specified in the
Command box will be carried out first, then the DDE command will be carried out. Use the 
%1 replaceable parameter in the command to represent a filename. The %1 is replaced with 
the file currently selected in File Manager when the command is carried out. When the Print 
option is selected, specify the DDE command for printing a file; for example, [open("%1")]
[print()][quit()]. 
The DDE Application Not Running area is not available unless you have specified a 
command in the DDE Message area. If the DDE Application Not Running area is empty, 
the value in the DDE Message area is used. 



Application
Specify the DDE application string to use to initiate a DDE conversation with the 

application specified in the Command area. If you do not complete this area, the application 
name in the Command area is used. 



Topic
Specify the DDE topic string to use to initiate a DDE conversation with the application

specified in the Command area. If you do not complete this area, "System" is used. 




